Added support for AVG8 (command-line scanner)

Please read this forum to stay up to date with our developments
Developer
User avatar
Posts: 4431
Joined: Tue Apr 20, 2004 3:43 pm

Added support for AVG8 (command-line scanner)

Postby Alexander Telegin » Tue Apr 01, 2008 8:42 pm

Dear eWall and MailFilter Users,

While Grisoft working on API for AVG 8 (the schedule at May 2008), you can use command-line scanner with eWall and MailFilter. Save attached file into AV directory and select AVG 8 in options. Don't forget to add eWall/MailFilter folders into AVG exclusion list to avoid blocking of infected emails. It's also recommended to add system TEMP folder into exclusions.

UPD: re-start eWall service after all.

Regards,
Alex
Attachments

[The extension cfg has been deactivated and can no longer be displayed.]


Expert
Posts: 463
Joined: Mon Apr 26, 2004 9:34 pm

Postby David Payer » Tue May 06, 2008 8:18 pm

Note to self..... stop/start the Ewall service before stating that the new AV didn't work.


Interesting that the AVG command line scanner shows a small display on the screen when it is run. In the lower right corner.

D

Developer
User avatar
Posts: 4431
Joined: Tue Apr 20, 2004 3:43 pm

Postby Alexander Telegin » Wed May 07, 2008 10:27 am

Thanks David, I've added a note. Yes, unfortunately it does, one small display per message.

Expert
User avatar
Posts: 571
Joined: Tue Apr 20, 2004 11:52 am

Avg 8.0

Postby Bob Escher » Sat May 10, 2008 2:25 am

I had a client complaining that towards the end of the day heroutbox was clogging up and nothing was going out. I looked at the xmail logfile while she tried to send a message.
I noticed the below and the system was very sluggish
5/9/2008 7:44:34 PM 6774 126250 The antivirus test failed: Time out.

Once I rebooted her email got sent out.

Any ideas

Bob Escher

Developer
User avatar
Posts: 4431
Joined: Tue Apr 20, 2004 3:43 pm

Postby Alexander Telegin » Sat May 10, 2008 12:18 pm

Maybe message was too large. Try to add following condition

if message size < 200 kb
and message is infected

Otherwise the only idea wait for better intergration with AVG8 or use another antivirus.

Junior Member
Posts: 2
Joined: Thu May 08, 2008 10:52 pm

AVG8 and MF

Postby chorrylan » Sat May 10, 2008 12:55 pm

hi,
this is just to note that this appears to be working for MF too though I had to
1. manually add the cmdline into the options pane as it seemd unabel to read it from the cfg file, and
2. until I rebooted the server it kept returning "test failed"

and.. the notification msg can be tuened off in AVG itself. (There's a "display notification icon" checkbox in the email scanner tab.

cheers,
Laurie

Developer
User avatar
Posts: 4431
Joined: Tue Apr 20, 2004 3:43 pm

Postby Alexander Telegin » Sat May 10, 2008 1:08 pm

Indeed, the command line was broken. Please re-download. I have disabled "notification icon" at email tab, but it still appear.

Return to Announcements

Who is online

Users browsing this forum: No registered users and 1 guest