Email blocked

Junior Member
Posts: 118
Joined: Thu Nov 15, 2007 12:02 pm
Location: Townsville, Australia

Email blocked

Postby Stuart » Tue Aug 23, 2016 10:17 pm

A email that has its IP address in the good list is constantly being blocked and I do not seem to be able to allow it to be delivered. Can you tell me what I need to do to let this mail through.

2016-08-24 07:43:00 10036 0 ------ Requested connection from 91.108.188.206, Country: Switzerland, SID:1608240743000000
2016-08-24 07:43:00 10036 16 Connected to 127.0.0.1:2525
2016-08-24 07:43:00 10036 16 <-- 220 mail.******.com.au
2016-08-24 07:43:00 10036 359 --> EHLO mta206l2.r.grouponmail.com.au
2016-08-24 07:43:00 10036 390 <-- 250-mail.******.com.au
2016-08-24 07:43:00 10036 390 <-- 250-SIZE 40480000
2016-08-24 07:43:00 10036 390 <-- 250-AUTH LOGIN PLAIN
2016-08-24 07:43:00 10036 390 <-- 250 HELP
2016-08-24 07:43:01 10036 733 --> MAIL FROM:<7a6664d6da01f12c08ffc61ef00eaa49b7e1ece381e64e60c157f947c2205e20@bounce.r.grouponmail.com.au>
2016-08-24 07:43:01 10036 749 +Filter: "Authentication Exceptions"
2016-08-24 07:43:01 10036 749 +Filter: "SPF Test"
2016-08-24 07:43:01 10036 1030 SPF result: PASS
2016-08-24 07:43:01 10036 1030 bounce.r.grouponmail.com.au: v=spf1 include:r.grouponmail.com.au ~all
2016-08-24 07:43:01 10036 1030 r.grouponmail.com.au: v=spf1 include:_spf.r.grouponmail.com ~all
2016-08-24 07:43:01 10036 1030 _spf.r.grouponmail.com: v=spf1 ip4:50.115.218.0/23 ip4:50.115.214.0/24 ip4:91.108.188.0/24 ip4:213.242.67.150 ip4:213.242.73.90
2016-08-24 07:43:01 10036 1030 +Filter: "Block bad senders"
2016-08-24 07:43:01 10036 1030 <-- 250 OK
2016-08-24 07:43:01 10036 1389 --> RCPT TO:<stuart@******.com.au>
2016-08-24 07:43:01 10036 1404 +Filter: "Block harvesters"
2016-08-24 07:43:01 10036 1404 +Filter: "Open relay prevention"
2016-08-24 07:43:01 10036 1404 +Filter: "Max recipient count", skip for recipient <stuart@******.com.au>
2016-08-24 07:43:01 10036 1404 <-- 250 OK
2016-08-24 07:43:02 10036 1763 --> DATA
2016-08-24 07:43:02 10036 1763 <-- 354 OK, send.
2016-08-24 07:44:22 10036 81885 !Error: client timeout: 80 sec
2016-08-24 07:44:22 10036 81932 Disconnect

Junior Member
Posts: 118
Joined: Thu Nov 15, 2007 12:02 pm
Location: Townsville, Australia

Sometimes incoming IP not passed to Mail Server

Postby Stuart » Tue Sep 20, 2016 10:21 pm

It seems that occasionally the external IP of the incoming email is shown as 127.0.0.1 (refer to hMailServer log beloww) in hMailServer and these emails are not able to be processed by hMailServer. The IP address of most incoming emails are passed to hMailServer and the mail is delivered correctly. The IP of the incoming email is correctly identified by eWall according to their logs as shown below but seems to be passed to hMailServer as 127.0.0.1 rather that 61.8.13.200. It seems that mail where this happens is not delivered, is there something that I can do to correct this behaviour?

I have read that the EWLSP does not work in all situations but it has been working well and I am not sure if this is an issue or not.

eWall Logs
2016-09-21 08:16:01 632 0 ------ Requested connection from 61.8.13.250, Country: Australia, SID:1609210816010000
2016-09-21 08:16:01 632 0 Connected to 127.0.0.1:2525
2016-09-21 08:16:01 632 15 <-- 220 mail.*********.com.au
2016-09-21 08:16:01 632 46 --> EHLO smtpout.my-vault.com.au
2016-09-21 08:16:01 632 46 <-- 250-mail.*********.com.au
2016-09-21 08:16:01 632 46 <-- 250-SIZE 40480000
2016-09-21 08:16:01 632 46 <-- 250-AUTH LOGIN PLAIN
2016-09-21 08:16:01 632 46 <-- 250 HELP
2016-09-21 08:16:01 632 93 --> MAIL FROM:<DonnaR@couttsredington.com.au> SIZE=46133
2016-09-21 08:16:01 632 93 The sender found in GOOD list, reason: Supplier - CouttsReddington
2016-09-21 08:16:01 632 93 +Filter: "SPF Test"
2016-09-21 08:16:01 632 93 Skip trusted sender
2016-09-21 08:16:01 632 93 +Filter: "Authentication Exceptions"
2016-09-21 08:16:01 632 93 +Filter: "Block bad senders"
2016-09-21 08:16:01 632 93 <-- 250 OK
2016-09-21 08:16:01 632 140 --> RCPT TO:<stuart@*********.com.au>
2016-09-21 08:16:01 632 140 +Filter: "Block harvesters"
2016-09-21 08:16:01 632 140 Skip trusted sender
2016-09-21 08:16:01 632 140 +Filter: "Open relay prevention"
2016-09-21 08:16:01 632 140 <-- 250 OK
2016-09-21 08:16:01 632 171 --> DATA
2016-09-21 08:16:01 632 187 <-- 354 OK, send.
2016-09-21 08:17:22 632 81183 !Error: client timeout: 80 sec
2016-09-21 08:17:22 632 81183 Disconnect

hMailServer Logs
"2016-09-21 08:16:01.519" "TCP - 127.0.0.1 connected to 127.0.0.1:2525."
"DEBUG" 4000 "2016-09-21 08:16:01.519" "TCP connection started for session 2456"
"SMTPD" 4000 2456 "2016-09-21 08:16:01.520" "127.0.0.1" "SENT: 220 mail.*********.com.au"
"SMTPD" 4012 2456 "2016-09-21 08:16:01.560" "127.0.0.1" "RECEIVED: EHLO smtpout.my-vault.com.au"
"SMTPD" 4012 2456 "2016-09-21 08:16:01.560" "127.0.0.1" "SENT: 250-mail.*********.com.au[nl]250-SIZE 40480000[nl]250-AUTH LOGIN PLAIN[nl]250 HELP"
"SMTPD" 4012 2456 "2016-09-21 08:16:01.600" "127.0.0.1" "RECEIVED: MAIL FROM:<DonnaR@couttsredington.com.au> SIZE=46133"
"DEBUG" 4012 "2016-09-21 08:16:01.601" "Total spam score: 0"
"SMTPD" 4012 2456 "2016-09-21 08:16:01.602" "127.0.0.1" "SENT: 250 OK"
"SMTPD" 4000 2456 "2016-09-21 08:16:01.646" "127.0.0.1" "RECEIVED: RCPT TO:<stuart@*********.com.au>"
"SMTPD" 4000 2456 "2016-09-21 08:16:01.647" "127.0.0.1" "SENT: 250 OK"
"DEBUG" 3948 "2016-09-21 08:16:11.187" "No messages to index."
"DEBUG" 3948 "2016-09-21 08:17:11.096" "No messages to index."
"DEBUG" 3964 "2016-09-21 08:17:22.571" "The read operation failed. Bytes transferred: 0 Remote IP: 127.0.0.1, Session: 2456, Code: 2, Message: End of file"
"DEBUG" 3964 "2016-09-21 08:17:22.571" "Deleting message file."
"DEBUG" 3964 "2016-09-21 08:17:22.571" "Ending session 2456"

Return to Filters and scripts

Who is online

Users browsing this forum: No registered users and 1 guest