Mailfilter not saving message to file

The filtering plug-in for ArGoSoft Mail Server (Pro and .NET)
Junior Member
Posts: 22
Joined: Thu Feb 14, 2008 2:37 pm

Mailfilter not saving message to file

Postby Torben » Thu Apr 09, 2009 1:59 pm

Hi everyone,

we set up mailfilter to save every regognized spam-email to a file. For some odd reason this does not work for certain messages.

This is, what the log-file says:
Code: Select all
09.04.2009 15:14:35   2184   165   Applying action 'save message to '{Subject}_{X-Paranoid-Prob}%_{X-MF-Time}_{X-MF-From}.eml''
09.04.2009 15:14:35   2184   165   File: C:\Programme\Server Side Solutions\MailFilter\Filtered\Spam\2009-04-09\__iso-8859-1_Q_Testmailblablabla_f_FCr_eine_Testmailblabla_f_FCr_einen___
09.04.2009 15:14:35   2184   165      __iso-8859-1_Q_Testdienstblubb___99%_15_14_34_external_sender@provider.de.eml
09.04.2009 15:14:35   2184   166   Error: Cannot create file "C:\Programme\Server Side Solutions\MailFilter\Filtered\Spam\2009-04-09\__iso-8859-1_Q_Adresspotenzialanfrage_f_FCr_eine_Testmailblabla_f_FCr_einen___
09.04.2009 15:14:35   2184   166      __iso-8859-1_Q_Testdienstblubb___99%_15_14_34_external_sender@provider.de.eml". Die Syntax f?r den Dateinamen, Verzeichnisnamen oder die Datentr?gerbezeichnung ist falsch
09.04.2009 15:14:35   2184   166   Applying action 'delete message'

The german error message sayas something like this: "The syntax for the file name, directory name or disk description is wrong".

If I try to create this file manually, there is no problem, so it is not the unusual filenamelength that creates this error... And other mails are saved without problem, so it does not have anything to do with the directory grants.

We are running Mailfilter 4.1.121 on Windows XP SP3 with Argosoft Mailserver 1.8.9.2 (I know, it is not the latest version, but according to the Changelog, we need none of the fixes approved since then).

Any Ideas?

Thanks in purpose!

Developer
User avatar
Posts: 4431
Joined: Tue Apr 20, 2004 3:43 pm

Postby Alexander Telegin » Thu Apr 09, 2009 3:54 pm


Junior Member
Posts: 22
Joined: Thu Feb 14, 2008 2:37 pm

Postby Torben » Fri Apr 17, 2009 12:44 pm

Thanks. I'll try and report whether it works or not.

Junior Member
Posts: 22
Joined: Thu Feb 14, 2008 2:37 pm

Postby Torben » Mon Apr 20, 2009 6:12 am

This does not work at all.

The eror message in the logs was not seen again. But now no files are saved at all although the logs don't say anything suspicious.

This is not what i wanted ;)

Junior Member
Posts: 22
Joined: Thu Feb 14, 2008 2:37 pm

Postby Torben » Thu Apr 23, 2009 12:01 pm

Arg... (again),

Sorry for the inconvenience. Your change works, but not in the way I expected. Now, all blanks in the whole path (even in the part of the path the user can define) are replaced by underscores, so the files where saved in a different directory then before. This way i haven't found them anymore and assumed they were not saved at all...

If you want to leave it this way you should mention, that blanks in the directory path are now replaced by underscores. I can live with this, so this is solved for me ;)

Thanks a lot!

Return to MailFilter - General

Who is online

Users browsing this forum: No registered users and 1 guest