authentication rule not working

Junior Member
Posts: 77
Joined: Wed Feb 06, 2008 12:09 am

authentication rule not working

Postby sicnezz » Tue Nov 24, 2009 10:44 am

i'm having this rules:

OnReply:
check for relay attempt (if user not local or unknown user - block it)

OnMessage:
check for: sender is local, is outgoing, sender is authenticated

the problem is: the "sender is authenticated" is always being ignored.
shouldn't it work because unwanted users already get banned OnReply?

thanks,
sic

Developer
User avatar
Posts: 4431
Joined: Tue Apr 20, 2004 3:43 pm

Postby Alexander Telegin » Tue Nov 24, 2009 10:50 am

Correct, OnReply event occurs at each server reply, before OnMessage.

Junior Member
Posts: 77
Joined: Wed Feb 06, 2008 12:09 am

Postby sicnezz » Tue Nov 24, 2009 11:03 am

'Alexander Telegin [SSS wrote:]Correct, OnReply event occurs at each server reply, before OnMessage.


that's what i mean - when the sender reaches OnMessage, he should be authenticated and the "sender is authenticated"-rule should fire - but it doesn't.

bug?

sic

Developer
User avatar
Posts: 4431
Joined: Tue Apr 20, 2004 3:43 pm

Postby Alexander Telegin » Tue Nov 24, 2009 11:07 am

It could be a bug or either sender is not local or not outgoing. Need to check the logs.

Junior Member
Posts: 77
Joined: Wed Feb 06, 2008 12:09 am

Postby sicnezz » Tue Nov 24, 2009 12:20 pm

'Alexander Telegin [SSS wrote:]It could be a bug or either sender is not local or not outgoing. Need to check the logs.


i've checked that. i added 3 separate rules for "sender is local", "outgoing" and 3rd "is authenticated". the first 2 rules where triggered but not the 3rd.

seems like the only way is to omit authentication-check but i'm not feeling well about it.

sic

Developer
User avatar
Posts: 4431
Joined: Tue Apr 20, 2004 3:43 pm

Postby Alexander Telegin » Tue Nov 24, 2009 12:22 pm

Please send me the log for that session, I'll explain what's happened there.

Junior Member
Posts: 77
Joined: Wed Feb 06, 2008 12:09 am

Postby sicnezz » Thu Nov 26, 2009 11:59 am

'Alexander Telegin [SSS wrote:]Please send me the log for that session, I'll explain what's happened there.


OnMessage:

26.11.2009 12:38:26 1582205 8312 Start Log!
26.11.2009 12:38:26 1582205 8312 -> Processing filter 'is outgoing'
26.11.2009 12:38:26 1582205 8312 Checking condition 'message is outgoing'
26.11.2009 12:38:26 1582205 8312 Applying action 'write 'LOG: outgoing' to log'
26.11.2009 12:38:26 1582205 8312 LOG: outgoing
26.11.2009 12:38:26 1582205 8312 -> Processing filter 'sender is local'
26.11.2009 12:38:26 1582205 8312 Checking condition 'sender is local'
26.11.2009 12:38:26 1582205 8312 Applying action 'write 'LOG: sender is local' to log'
26.11.2009 12:38:26 1582205 8312 LOG: sender is local
26.11.2009 12:38:26 1582205 8312 -> Processing filter 'sender is authenticated'
26.11.2009 12:38:26 1582205 8312 Checking condition 'sender is authenticated'
26.11.2009 12:38:26 1582205 8312 -> Processing filter 'Local sender: Whitelist Check (Log)'
..
..
..
26.11.2009 12:38:26 1582205 8578 Mail server accepted data transfer
26.11.2009 12:38:27 1582205 9484 Event: ONREPLY
26.11.2009 12:38:27 1582205 9484 < 250 Message accepted for delivery.
26.11.2009 12:38:27 1582205 9593 Event: ONCOMMAND
26.11.2009 12:38:27 1582205 9593 > QUIT

sender is local + message is outgoing - but authentication doesnt fire :/
i can't remove "sender is authenticated" because it would enable spammers to get through if they'd match whitelist entries.

thx,
sic

Developer
User avatar
Posts: 4431
Joined: Tue Apr 20, 2004 3:43 pm

Postby Alexander Telegin » Thu Nov 26, 2009 12:11 pm

Please post the entire session log in PM.

Junior Member
Posts: 77
Joined: Wed Feb 06, 2008 12:09 am

Postby sicnezz » Thu Nov 26, 2009 12:21 pm

'Alexander Telegin [SSS wrote:]Please post the entire session log in PM.


seems like i found the problem.
i need to use "is NOT authenticated" to first disconnect all spammers which try to send out.
then i can omit "is authenticated" from the following filter rules.

dunno if this is a bug - but as this works out for me i'm happy :)

Return to Filters and scripts

Who is online

Users browsing this forum: No registered users and 1 guest